Emoncms3 language issue

There is no graph in Realtime graph when chosen language is other than English (fr.jpg).

When language is English graph is shown correctly (en.jpg). Why?



alco's picture

Re: Emoncms3 language issue

Hi got a similar problem. I only see the dail graphic in my dashboards. when I'm trying to add an other type like a line graph of bar graph it's not showing anything! only the borders...

see my demo dashboard at http://energy.bluemotica.nl/alco&id=1

even this striped down graphic don't work:

<div class="graph" feed="voltage" id="cab1"></div>


And second, If I want to change the language from en_EN to nl_NL it's not working.. Nothing change at all?!? Even an apache2 restart won’t help.... (and I made the NL dutch, translation myself to the emoncms github!)

So last night I made a complete new emoncms setup  (new DB, new files at apache www) off course with the latest github sources (even tried the DEV version!) but nothing works...still no show of graphics at the dashboards.

But something is odd... when I use the Feeds real-time of raw button. At the Feeds tab. it shows the graphics right-a-way! but when I use it at a dashboards...no show!

maybe I found a bug???

I use CKeditor ..and also installed the filemanager... but at the " INSTALL SIMOGEO FILEMANAGER HERE.txt" is a comment for change a file...but what file? no name is given... and Do I have to apply the github changes at point 3 from this file?

install from https://github.com/simogeo/Filemanager in emoncms3_install_dir/Includes/simogeo-Filemanager
- copy simogeo-Filemanager/scripts/filemanager.config.js.default  to simogeo-Filemanager/scripts/filemanager.config.js
- change file
    var fileRoot = '/' + am + 'userfiles/';
    var fileRoot = '/';
- apply these changes too

 maybe this bug is something to do with that? But...it's a file-manager..not an graphic thing..so I could be something else....


 and If somebody wan't to take a look at my feeds ..feel free to ask my credentials.


Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.