emoncms on windows trouble

Hi all, new to this forum, please bear with me for newbie questions... 

I installed and got emoncms to work on my windows machine using Wamp, mysql, etc as described in the help. All pages open just fine. It all runs on port 80. Web server binds to localhost and to the actual IP address which is in 192-space. 

I have a small program that sends 3 data points out every 10 seconds; I didn't write it myself but it works great with my emoncms.org account: 3 inputs & feeds are created automatically, and then updated continuously. The program runs on an easyio controller which is on the same subnet than my newly installed emoncms server. 

So, now I am changing the IP address and the API key in the program and it fails to post anything! No error message, nothing. The apache log is even full of http code 200 for "ok" so the program IS connecting... (i.e. not a firewall issue either, it's off, anyway).  

It's driving me crazy :-/ Any suggestions? maybe something wrong in the mysql settings?? I tried "update and check database", it produces no output. A good thing, presumably? 

if anyone wants to try posting some data to it, have at it... the server is at http://negawatt.dyndns.org, the r/w api key is b613bb1e2836271a1f146733fcc3064c



Robert Wall's picture

Re: emoncms on windows trouble

Is emoncms in the root directory (as seen from the web side) of your WAMP server? If not, you need the directory in the address (" char basedir[] = "/emoncms5";  " ) for example. [Edited]

Are you using "/input/post.json?"  (I have problems with /api/post...)?

[Edit] I manually sent it


and it replied ok to me. I sent it /api/  and it replied "" - that's right, two double quotes with nothing in between. This is a known problem and I thought all the examples had been updated to use /input/.

Automate's picture

Re: emoncms on windows trouble

I'm have the same problems on a new install of Windows, see here



Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.