(SOLVED) Inputs page loading....


I've just been upgrading to 9.31 from 9.20. This is on Jessie Lite on a PiB and installed based on Paul's Pi Installation guide.

I decided to go back a stage to a working image I had as I also wanted to include recent Jessie updates to create a new master image that I could save again.

Everything went fine until I did the emoncms upgrade. Then when I went to the Inputs page it just says 'loading...'

There was some discussion in another thread about the inability to create feeds that mentions a problem like this and the fix was to update redis. I did this but it hasn't helped.

I know emonhub is working as I can see data from my system on emoncms.org but obviously can't see any inputs locally due to the inputs page not working.

Any help much appreciated.


PS More info after a few trials

I have a stable image Jessie Lite (with update and upgrade, so latest version)  with emoncms 9.20 on a PiB.

Upgrading emoncms to 9.31, correcting the settings.php and then upgrading phpredis gives me the error with the Inputs page just showing loading....

If I do the phpredis upgrade first everything still runs fine, so I can see the inputs on the inputs page after a restart (shutdown -r). When I then upgrade to 9.31 (and fix settings.php) I can from a browser that the inputs are still there after a restart but when I leave the page to go to Admin and then back to the Inputs page I get the same issue the page just says loading... at the top.

Any ideas?

Bramco's picture

Re: (SOLVED) Inputs page loading....

The fix was to repeat one of the steps in the installation guide.

sudo chown www-data:root /var/lib/{phpfiwa,phpfina,phptimeseries}

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.